Repository navigation
🔧 chore(deps): bump lint-staged - #17
Conversation
- 🔧 require the current lint-staged major for dev tooling
|
✅ Approved No new findings. Clean dependency bump of |
|
| Filename | Overview |
|---|---|
| package.json | 将 lint-staged 从 ^16.4.0 升级到 ^17.0.4;缺少 engines 字段来声明新的 Node >=22.22.1 要求 |
| pnpm-lock.yaml | 锁文件正确反映了 lint-staged@17.0.4 的依赖图:commander 和 colorette 移除,yaml 改为 optionalDependencies,listr2/tinyexec/wrap-ansi 同步升级 |
Flowchart
%%{init: {'theme': 'neutral'}}%%
flowchart TD
A["lint-staged@17.0.4\nNode >=22.22.1"] --> B["listr2@10.2.1\nNode >=22.13.0"]
A --> C["picomatch@4.0.4"]
A --> D["string-argv@0.3.2"]
A --> E["tinyexec@1.1.2\nNode >=18"]
A --> F["yaml@2.9.0\n(optional)"]
B --> G["cli-truncate@5.2.0"]
B --> H["eventemitter3@5.0.4"]
B --> I["log-update@6.1.0"]
B --> J["rfdc@1.4.1"]
B --> K["wrap-ansi@10.0.0\nNode >=20"]
subgraph "已移除"
L["commander@14.0.3"]
M["colorette@2.0.20"]
end
Comments Outside Diff (1)
-
package.json, line 10 (link)lint-staged@17将最低 Node.js 版本要求从>=20.17提升到>=22.22.1(通过listr2@10传递依赖进一步要求>=22.13.0)。package.json目前没有engines字段,贡献者在 Node 20.x 或 21.x 环境下运行lint-staged时会静默失败或收到难以排查的错误。建议补充engines字段以明确记录此约束。
Reviews (1): Last reviewed commit: "🔧 chore(deps): bump lint-staged" | Re-trigger Greptile
There was a problem hiding this comment.
Pull request overview
This PR updates the repo’s developer tooling by bumping lint-staged to the latest major version and regenerating the corresponding pnpm-lock.yaml entries to reflect the updated dependency graph.
Changes:
- Bump
lint-stagedfrom^16.4.0to^17.0.4inpackage.json. - Refresh
pnpm-lock.yamlto capturelint-staged@17and transitive dependency updates (e.g.,listr2,tinyexec,yaml,wrap-ansi) and removals (e.g.,commander,colorette).
Reviewed changes
Copilot reviewed 1 out of 2 changed files in this pull request and generated 1 comment.
| File | Description |
|---|---|
| package.json | Updates lint-staged dependency to ^17.0.4. |
| pnpm-lock.yaml | Regenerates lockfile entries for lint-staged@17 and updated transitive dependencies (including new Node engine constraints). |
Files not reviewed (1)
- pnpm-lock.yaml: Language not supported
💡 Add Copilot custom instructions for smarter, more guided reviews. Learn how to get started.
| "globals": "^17.6.0", | ||
| "husky": "^9.1.7", | ||
| "lint-staged": "^16.4.0", | ||
| "lint-staged": "^17.0.4", |
Summary
lint-stagedfrom^16.4.0to^17.0.4Risk
lint-staged17 raises the Node engine requirement from>=20.17to>=22.22.1; this repo has no lower Node pin, and local validation ran on Node 24.14.0.lintstagedrc.mjsValidation
pnpm install --frozen-lockfilepnpm run lintpnpm exec lint-staged --versionpnpm outdated --format json